package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)"[^"{}]+":\s*{[^{}]*"_href":[^{}]*}`)
var str = `[{
"name": "Test",
"junkAttributeA": {
"_href": "string",
"_type": "string"
},
"junkAttributeB": {
"_href": "string",
"_type": "string"
}
}]`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}