#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = ".(?R)?<BckSp>"
Local $sString = "Helllo<BckSp><BckSp>o world"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)