using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @".(?R)?<BckSp>";
string substitution = @"";
string input = @"Helllo<BckSp><BckSp>o world";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}