const regex = /.(?R)?<BckSp>/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('.(?R)?<BckSp>', 'g')
const str = `Helllo<BckSp><BckSp>o world`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);