use strict;
my $str = 'Helllo<BckSp><BckSp>o world';
my $regex = qr/.(?R)?<BckSp>/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";