import Foundation
let pattern = #".(?R)?<BckSp>"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"Helllo<BckSp><BckSp>o world"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)