using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?P<sale_items>\$.+(?<=\.99)$)";
string input = @"$14.99
$156.98
$85.99
$43.97
$1.98
$83.74
$1,601.99
1
12
123
123,456
123,456,789
123,456,789.01";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}