$re = '/(?P<sale_items>\$.+(?<=\.99)$)/m';
$str = '$14.99
$156.98
$85.99
$43.97
$1.98
$83.74
$1,601.99
1
12
123
123,456
123,456,789
123,456,789.01';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);