import re
regex = re.compile(r"(?P<sale_items>\$.+(?<=\.99)$)", flags=re.MULTILINE)
test_str = ("$14.99\n"
"$156.98\n"
"$85.99\n"
"$43.97\n"
"$1.98\n"
"$83.74\n"
"$1,601.99\n\n"
"1\n"
"12\n"
"123\n"
"123,456\n"
"123,456,789\n"
"123,456,789.01")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")