#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?Jmix)^(?'request'.+?);.*](?(?=(.*,.*))(((?'block'.*)?[,.](?'stain'.*)?)?)|((?'block'.*)?))"
Local $sString = "12345-21;[65]1A,HE" & @CRLF & _
"12345-21;[65]1A," & @CRLF & _
"12345-21;[65]1A" & @CRLF & _
"12345-21;[65],HE" & @CRLF & _
"12345-21;[65]," & @CRLF & _
"12345-21;[65]" & @CRLF & _
"12345-21;" & @CRLF & _
"12345-21," & @CRLF & _
"A_12345-21;[65]1A,HE" & @CRLF & _
"A_12345-21;[65]1A," & @CRLF & _
"A_12345-21;[65]1A" & @CRLF & _
"A_12345-21;[65],HE" & @CRLF & _
"A_12345-21;[65]," & @CRLF & _
"A_12345-21;[65]" & @CRLF & _
"12345-21;" & @CRLF & _
"12345-21," & @CRLF & _
"A.12345-21;[65]1A,HE" & @CRLF & _
"A.12345-21;[65]1A," & @CRLF & _
"A.12345-21;[65]1A" & @CRLF & _
"A.12345-21;[65],HE" & @CRLF & _
"A.12345-21;[65]," & @CRLF & _
"A.12345-21;[65]" & @CRLF & _
"12345-21;" & @CRLF & _
"12345-21," & @CRLF & _
"A.12345-21;[65]1PCS1,Ki-67" & @CRLF & _
"A.12345-21;[65]1A," & @CRLF & _
"A.12345-21;[65]1A" & @CRLF & _
"A.12345-21;[65],HE" & @CRLF & _
"A.12345-21;[65]," & @CRLF & _
"A.12345-21;[65]" & @CRLF & _
"12345-21;" & @CRLF & _
"12345-21,"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")