import Foundation
// WARNING: You included a flag that Swift doesn't support: J
// Wehn this flag is set, it allows duplicated capturing group names.
// By default, Swift captures only the last value matched for a repeated capture group.
// As an alternative, the pattern can be modified to contain one capturing group per group you want to get in the result.
let pattern = #"^(?'request'.+?);.*](?(?=(.*,.*))(((?'block'.*)?[,.](?'stain'.*)?)?)|((?'block'.*)?))"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive, .allowCommentsAndWhitespace])
let testString = #"""
12345-21;[65]1A,HE
12345-21;[65]1A,
12345-21;[65]1A
12345-21;[65],HE
12345-21;[65],
12345-21;[65]
12345-21;
12345-21,
A_12345-21;[65]1A,HE
A_12345-21;[65]1A,
A_12345-21;[65]1A
A_12345-21;[65],HE
A_12345-21;[65],
A_12345-21;[65]
12345-21;
12345-21,
A.12345-21;[65]1A,HE
A.12345-21;[65]1A,
A.12345-21;[65]1A
A.12345-21;[65],HE
A.12345-21;[65],
A.12345-21;[65]
12345-21;
12345-21,
A.12345-21;[65]1PCS1,Ki-67
A.12345-21;[65]1A,
A.12345-21;[65]1A
A.12345-21;[65],HE
A.12345-21;[65],
A.12345-21;[65]
12345-21;
12345-21,
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)