$re = '/^(?\'request\'.+?);.*](?(?=(.*,.*))(((?\'block\'.*)?[,.](?\'stain\'.*)?)?)|((?\'block\'.*)?))/Jmix';
$str = '12345-21;[65]1A,HE
12345-21;[65]1A,
12345-21;[65]1A
12345-21;[65],HE
12345-21;[65],
12345-21;[65]
12345-21;
12345-21,
A_12345-21;[65]1A,HE
A_12345-21;[65]1A,
A_12345-21;[65]1A
A_12345-21;[65],HE
A_12345-21;[65],
A_12345-21;[65]
12345-21;
12345-21,
A.12345-21;[65]1A,HE
A.12345-21;[65]1A,
A.12345-21;[65]1A
A.12345-21;[65],HE
A.12345-21;[65],
A.12345-21;[65]
12345-21;
12345-21,
A.12345-21;[65]1PCS1,Ki-67
A.12345-21;[65]1A,
A.12345-21;[65]1A
A.12345-21;[65],HE
A.12345-21;[65],
A.12345-21;[65]
12345-21;
12345-21,';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);