const regex = /^(?'request'.+?);.*](?(?=(.*,.*))(((?'block'.*)?[,.](?'stain'.*)?)?)|((?'block'.*)?))/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?\'request\'.+?);.*](?(?=(.*,.*))(((?\'block\'.*)?[,.](?\'stain\'.*)?)?)|((?\'block\'.*)?))', 'gmi')
const str = `12345-21;[65]1A,HE
12345-21;[65]1A,
12345-21;[65]1A
12345-21;[65],HE
12345-21;[65],
12345-21;[65]
12345-21;
12345-21,
A_12345-21;[65]1A,HE
A_12345-21;[65]1A,
A_12345-21;[65]1A
A_12345-21;[65],HE
A_12345-21;[65],
A_12345-21;[65]
12345-21;
12345-21,
A.12345-21;[65]1A,HE
A.12345-21;[65]1A,
A.12345-21;[65]1A
A.12345-21;[65],HE
A.12345-21;[65],
A.12345-21;[65]
12345-21;
12345-21,
A.12345-21;[65]1PCS1,Ki-67
A.12345-21;[65]1A,
A.12345-21;[65]1A
A.12345-21;[65],HE
A.12345-21;[65],
A.12345-21;[65]
12345-21;
12345-21,`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}