use strict;
my $str = '12345-21;[65]1A,HE
12345-21;[65]1A,
12345-21;[65]1A
12345-21;[65],HE
12345-21;[65],
12345-21;[65]
12345-21;
12345-21,
A_12345-21;[65]1A,HE
A_12345-21;[65]1A,
A_12345-21;[65]1A
A_12345-21;[65],HE
A_12345-21;[65],
A_12345-21;[65]
12345-21;
12345-21,
A.12345-21;[65]1A,HE
A.12345-21;[65]1A,
A.12345-21;[65]1A
A.12345-21;[65],HE
A.12345-21;[65],
A.12345-21;[65]
12345-21;
12345-21,
A.12345-21;[65]1PCS1,Ki-67
A.12345-21;[65]1A,
A.12345-21;[65]1A
A.12345-21;[65],HE
A.12345-21;[65],
A.12345-21;[65]
12345-21;
12345-21,';
my $regex = qr/^(?'request'.+?);.*](?(?=(.*,.*))(((?'block'.*)?[,.](?'stain'.*)?)?)|((?'block'.*)?))/mixp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}