import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?'request'.+?);.*](?(?=(.*,.*))(((?'block'.*)?[,.](?'stain'.*)?)?)|((?'block'.*)?))";
final String string = "12345-21;[65]1A,HE\n"
+ "12345-21;[65]1A,\n"
+ "12345-21;[65]1A\n"
+ "12345-21;[65],HE\n"
+ "12345-21;[65],\n"
+ "12345-21;[65]\n"
+ "12345-21;\n"
+ "12345-21,\n"
+ "A_12345-21;[65]1A,HE\n"
+ "A_12345-21;[65]1A,\n"
+ "A_12345-21;[65]1A\n"
+ "A_12345-21;[65],HE\n"
+ "A_12345-21;[65],\n"
+ "A_12345-21;[65]\n"
+ "12345-21;\n"
+ "12345-21,\n"
+ "A.12345-21;[65]1A,HE\n"
+ "A.12345-21;[65]1A,\n"
+ "A.12345-21;[65]1A\n"
+ "A.12345-21;[65],HE\n"
+ "A.12345-21;[65],\n"
+ "A.12345-21;[65]\n"
+ "12345-21;\n"
+ "12345-21,\n"
+ "A.12345-21;[65]1PCS1,Ki-67\n"
+ "A.12345-21;[65]1A,\n"
+ "A.12345-21;[65]1A\n"
+ "A.12345-21;[65],HE\n"
+ "A.12345-21;[65],\n"
+ "A.12345-21;[65]\n"
+ "12345-21;\n"
+ "12345-21,";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE | Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}