# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?<=""{[^{}\n]*),(?=[^{}\n]*}"")/","/gm;t' <<< "some, text \"\"{one,2two space,three-dash,four}\"\" some, text \"\"{alpha,bravo space - dash,charlie}\"\" some text';
"