$re = '/(?<=""{[^{}\n]*),(?=[^{}\n]*}"")/m';
$str = 'some, text ""{one,2two space,three-dash,four}"" some, text ""{alpha,bravo space - dash,charlie}"" some text\';
';
$subst = "\",\"";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;