use strict;
my $str = 'some, text ""{one,2two space,three-dash,four}"" some, text ""{alpha,bravo space - dash,charlie}"" some text\';
';
my $regex = qr/(?<=""{[^{}\n]*),(?=[^{}\n]*}"")/mp;
my $subst = '","';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";