import Foundation
let pattern = #"(?<=""{[^{}\n]*),(?=[^{}\n]*}"")"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
some, text ""{one,2two space,three-dash,four}"" some, text ""{alpha,bravo space - dash,charlie}"" some text';
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"",""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)