const regex = /(?<=""{[^{}\n]*),(?=[^{}\n]*}"")/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=""{[^{}\\n]*),(?=[^{}\\n]*}"")', 'gm')
const str = `some, text ""{one,2two space,three-dash,four}"" some, text ""{alpha,bravo space - dash,charlie}"" some text';
`;
const subst = `","`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);