re = /(?<=""{[^{}\n]*),(?=[^{}\n]*}"")/m
str = 'some, text ""{one,2two space,three-dash,four}"" some, text ""{alpha,bravo space - dash,charlie}"" some text\';
'
subst = '","'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result