using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\w*(?:[aeiou]{2,})\w*(?:[aeiou]{2,})\w*)";
string input = @"words that contains 2 or more letters sequesnces and some triiiiple visionproof, steamier, preequip";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}