// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(\w*(?:[aeiou]{2,})\w*(?:[aeiou]{2,})\w*)").unwrap();
let string = "words that contains 2 or more letters sequesnces and some triiiiple visionproof, steamier, preequip";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}