re = /(\w*(?:[aeiou]{2,})\w*(?:[aeiou]{2,})\w*)/
str = 'words that contains 2 or more letters sequesnces and some triiiiple visionproof, steamier, preequip'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end