package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(\w*(?:[aeiou]{2,})\w*(?:[aeiou]{2,})\w*)`)
var str = `words that contains 2 or more letters sequesnces and some triiiiple visionproof, steamier, preequip`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}