const regex = /(\w*(?:[aeiou]{2,})\w*(?:[aeiou]{2,})\w*)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\w*(?:[aeiou]{2,})\\w*(?:[aeiou]{2,})\\w*)', 'g')
const str = `words that contains 2 or more letters sequesnces and some triiiiple visionproof, steamier, preequip`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}