$re = '/(\w*(?:[aeiou]{2,})\w*(?:[aeiou]{2,})\w*)/';
$str = 'words that contains 2 or more letters sequesnces and some triiiiple visionproof, steamier, preequip';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);