#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?msi)\(\s*\d+\s\).*?(?:^$|- - - -)"
Local $sString = "( 2 )" & @CRLF & _
"01.02.2014 - ННННННН кем( орган): ЙЙЙЙЙЙЙЙ " & @CRLF & _
"ЙЙЙЙЙЙЙЙЙЙЙЙЙЙЙЙЙ " & @CRLF & _
"статьи: ЦЦЦЦЦЦЦЦЦЦЦЦЦЦЦЦ" & @CRLF & _
"УУУУУУУУУУУУУУУУУ Срок: КККККККККККККККККККК" & @CRLF & _
"" & @CRLF & _
"( 3 )" & @CRLF & _
"01.01.2014 - ННННННННН кем( орган): ЙЙЙЙЙЙЙЙЙЙ " & @CRLF & _
"ЙЙЙЙЙЙЙЙЙЙЙЙЙЙЙЙЙ " & @CRLF & _
"ЙЙЙЙЙЙЙЙЙЙ ЙЙЙЙЙЙЙЙЙЙЙЙЙ" & @CRLF & _
"статьи: ЦЦЦЦЦЦЦЦЦЦЦЦЦЦЦЦ" & @CRLF & _
"УУУУУУУУУУУУУУУУУ Срок: КККККККККККККККККККК" & @CRLF & _
"Комментарии : ЕЕЕЕЕЕЕЕЕЕЕЕЕЕЕЕЕЕ" & @CRLF & _
"Дополнительные отметки: ФФФФФФФФФФФФФФФФФФФФФФФ" & @CRLF & _
"ФФФФФФФФФФФФФФФ" & @CRLF & _
"ФФФФФФФФФФФФФФФФФФ Кем : ЯЯЯЯЯЯЯЯЯЯЯЯЯЯЯЯЯЯ" & @CRLF & _
"ЯЯЯЯЯЯЯЯЯЯЯЯЯЯЯЯЯЯЯЯЯЯЯЯЯЯЯЯЯЯЯЯЯЯ" & @CRLF & _
"" & @CRLF & _
"( 4 )" & @CRLF & _
"08.04.2014 - ННННННННН кем( орган): ЙЙЙЙЙЙЙЙЙЙ " & @CRLF & _
"ЙЙЙЙЙЙЙЙЙЙЙЙЙЙЙЙЙ " & @CRLF & _
"ЙЙЙЙЙЙЙЙЙЙ ЙЙЙЙЙЙЙЙЙЙЙЙЙ" & @CRLF & _
"статьи: ЦЦЦЦЦЦЦЦЦЦЦЦЦЦЦЦ" & @CRLF & _
"УУУУУУУУУУУУУУУУУ Срок: КККККККККККККККККККК" & @CRLF & _
"Комментарии : ЕЕЕЕЕЕЕЕЕЕЕЕЕЕЕЕЕЕ" & @CRLF & _
"Дополнительные отметки: ФФФФФФФФФФФФФФФФФФФФФФФ" & @CRLF & _
"ФФФФФФФФФФФФФФФ" & @CRLF & _
"ФФФФФФФФФФФФФФФФФФ Кем : ЯЯЯЯЯЯЯЯЯЯЯЯЯЯЯЯЯЯ" & @CRLF & _
"ЯЯЯЯЯЯЯЯЯЯЯЯЯЯЯЯЯЯЯЯЯЯЯЯЯЯЯЯЯЯЯЯЯЯ" & @CRLF & _
"Срок: ССССССССССССССССССССССССССССССССССССС" & @CRLF & _
"СССССССССССССССССССССССССССС" & @CRLF & _
"22.12.2014 - ННННННННННННННН : НННННННННННННННН " & @CRLF & _
"НННННННННН. Убыл в: ЗЗЗЗЗЗЗЗЗЗЗЗЗЗЗЗЗЗЗЗЗЗЗЗЗЗЗЗ " & @CRLF & _
"ЗЗЗЗЗЗЗЗЗЗЗЗЗЗ" & @CRLF & _
"" & @CRLF & _
"( 5 )" & @CRLF & _
"03.04.2017 - НННННННННННН кем( орган): ЙЙЙЙЙЙЙЙЙЙЙЙЙ" & @CRLF & _
"ЙЙЙЙЙЙЙЙЙЙЙЙЙЙЙЙЙЙЙЙ" & @CRLF & _
"статьи: ЦЦЦЦЦЦЦЦЦЦЦЦЦЦЦЦЦЦЦЦЦЦЦЦЦЦЦЦЦЦЦЦ" & @CRLF & _
"ууууууууууууууууууууу Срок: КККККККККККККККККККККК" & @CRLF & _
"Комментарии : ЕЕЕЕЕЕЕЕЕЕЕЕЕЕЕЕЕ" & @CRLF & _
"Дополнительные отметки: ФФФФФФФФФФФФФФФФФФФФФФФФФФФФФФФ" & @CRLF & _
"- - - -"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")