use strict;
my $str = '( 2 )
01.02.2014 - ННННННН кем( орган): ЙЙЙЙЙЙЙЙ
ЙЙЙЙЙЙЙЙЙЙЙЙЙЙЙЙЙ
статьи: ЦЦЦЦЦЦЦЦЦЦЦЦЦЦЦЦ
УУУУУУУУУУУУУУУУУ Срок: КККККККККККККККККККК
( 3 )
01.01.2014 - ННННННННН кем( орган): ЙЙЙЙЙЙЙЙЙЙ
ЙЙЙЙЙЙЙЙЙЙЙЙЙЙЙЙЙ
ЙЙЙЙЙЙЙЙЙЙ ЙЙЙЙЙЙЙЙЙЙЙЙЙ
статьи: ЦЦЦЦЦЦЦЦЦЦЦЦЦЦЦЦ
УУУУУУУУУУУУУУУУУ Срок: КККККККККККККККККККК
Комментарии : ЕЕЕЕЕЕЕЕЕЕЕЕЕЕЕЕЕЕ
Дополнительные отметки: ФФФФФФФФФФФФФФФФФФФФФФФ
ФФФФФФФФФФФФФФФ
ФФФФФФФФФФФФФФФФФФ Кем : ЯЯЯЯЯЯЯЯЯЯЯЯЯЯЯЯЯЯ
ЯЯЯЯЯЯЯЯЯЯЯЯЯЯЯЯЯЯЯЯЯЯЯЯЯЯЯЯЯЯЯЯЯЯ
( 4 )
08.04.2014 - ННННННННН кем( орган): ЙЙЙЙЙЙЙЙЙЙ
ЙЙЙЙЙЙЙЙЙЙЙЙЙЙЙЙЙ
ЙЙЙЙЙЙЙЙЙЙ ЙЙЙЙЙЙЙЙЙЙЙЙЙ
статьи: ЦЦЦЦЦЦЦЦЦЦЦЦЦЦЦЦ
УУУУУУУУУУУУУУУУУ Срок: КККККККККККККККККККК
Комментарии : ЕЕЕЕЕЕЕЕЕЕЕЕЕЕЕЕЕЕ
Дополнительные отметки: ФФФФФФФФФФФФФФФФФФФФФФФ
ФФФФФФФФФФФФФФФ
ФФФФФФФФФФФФФФФФФФ Кем : ЯЯЯЯЯЯЯЯЯЯЯЯЯЯЯЯЯЯ
ЯЯЯЯЯЯЯЯЯЯЯЯЯЯЯЯЯЯЯЯЯЯЯЯЯЯЯЯЯЯЯЯЯЯ
Срок: ССССССССССССССССССССССССССССССССССССС
СССССССССССССССССССССССССССС
22.12.2014 - ННННННННННННННН : НННННННННННННННН
НННННННННН. Убыл в: ЗЗЗЗЗЗЗЗЗЗЗЗЗЗЗЗЗЗЗЗЗЗЗЗЗЗЗЗ
ЗЗЗЗЗЗЗЗЗЗЗЗЗЗ
( 5 )
03.04.2017 - НННННННННННН кем( орган): ЙЙЙЙЙЙЙЙЙЙЙЙЙ
ЙЙЙЙЙЙЙЙЙЙЙЙЙЙЙЙЙЙЙЙ
статьи: ЦЦЦЦЦЦЦЦЦЦЦЦЦЦЦЦЦЦЦЦЦЦЦЦЦЦЦЦЦЦЦЦ
ууууууууууууууууууууу Срок: КККККККККККККККККККККК
Комментарии : ЕЕЕЕЕЕЕЕЕЕЕЕЕЕЕЕЕ
Дополнительные отметки: ФФФФФФФФФФФФФФФФФФФФФФФФФФФФФФФ
- - - -';
my $regex = qr/\(\s*\d+\s\).*?(?:^$|- - - -)/msip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}