// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?msi)\(\s*\d+\s\).*?(?:^$|- - - -)").unwrap();
let string = "( 2 )
01.02.2014 - ННННННН кем( орган): ЙЙЙЙЙЙЙЙ
ЙЙЙЙЙЙЙЙЙЙЙЙЙЙЙЙЙ
статьи: ЦЦЦЦЦЦЦЦЦЦЦЦЦЦЦЦ
УУУУУУУУУУУУУУУУУ Срок: КККККККККККККККККККК
( 3 )
01.01.2014 - ННННННННН кем( орган): ЙЙЙЙЙЙЙЙЙЙ
ЙЙЙЙЙЙЙЙЙЙЙЙЙЙЙЙЙ
ЙЙЙЙЙЙЙЙЙЙ ЙЙЙЙЙЙЙЙЙЙЙЙЙ
статьи: ЦЦЦЦЦЦЦЦЦЦЦЦЦЦЦЦ
УУУУУУУУУУУУУУУУУ Срок: КККККККККККККККККККК
Комментарии : ЕЕЕЕЕЕЕЕЕЕЕЕЕЕЕЕЕЕ
Дополнительные отметки: ФФФФФФФФФФФФФФФФФФФФФФФ
ФФФФФФФФФФФФФФФ
ФФФФФФФФФФФФФФФФФФ Кем : ЯЯЯЯЯЯЯЯЯЯЯЯЯЯЯЯЯЯ
ЯЯЯЯЯЯЯЯЯЯЯЯЯЯЯЯЯЯЯЯЯЯЯЯЯЯЯЯЯЯЯЯЯЯ
( 4 )
08.04.2014 - ННННННННН кем( орган): ЙЙЙЙЙЙЙЙЙЙ
ЙЙЙЙЙЙЙЙЙЙЙЙЙЙЙЙЙ
ЙЙЙЙЙЙЙЙЙЙ ЙЙЙЙЙЙЙЙЙЙЙЙЙ
статьи: ЦЦЦЦЦЦЦЦЦЦЦЦЦЦЦЦ
УУУУУУУУУУУУУУУУУ Срок: КККККККККККККККККККК
Комментарии : ЕЕЕЕЕЕЕЕЕЕЕЕЕЕЕЕЕЕ
Дополнительные отметки: ФФФФФФФФФФФФФФФФФФФФФФФ
ФФФФФФФФФФФФФФФ
ФФФФФФФФФФФФФФФФФФ Кем : ЯЯЯЯЯЯЯЯЯЯЯЯЯЯЯЯЯЯ
ЯЯЯЯЯЯЯЯЯЯЯЯЯЯЯЯЯЯЯЯЯЯЯЯЯЯЯЯЯЯЯЯЯЯ
Срок: ССССССССССССССССССССССССССССССССССССС
СССССССССССССССССССССССССССС
22.12.2014 - ННННННННННННННН : НННННННННННННННН
НННННННННН. Убыл в: ЗЗЗЗЗЗЗЗЗЗЗЗЗЗЗЗЗЗЗЗЗЗЗЗЗЗЗЗ
ЗЗЗЗЗЗЗЗЗЗЗЗЗЗ
( 5 )
03.04.2017 - НННННННННННН кем( орган): ЙЙЙЙЙЙЙЙЙЙЙЙЙ
ЙЙЙЙЙЙЙЙЙЙЙЙЙЙЙЙЙЙЙЙ
статьи: ЦЦЦЦЦЦЦЦЦЦЦЦЦЦЦЦЦЦЦЦЦЦЦЦЦЦЦЦЦЦЦЦ
ууууууууууууууууууууу Срок: КККККККККККККККККККККК
Комментарии : ЕЕЕЕЕЕЕЕЕЕЕЕЕЕЕЕЕ
Дополнительные отметки: ФФФФФФФФФФФФФФФФФФФФФФФФФФФФФФФ
- - - -";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}