import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\(\\s*\\d+\\s\\).*?(?:^$|- - - -)";
final String string = "( 2 )\n"
+ "01.02.2014 - ННННННН кем( орган): ЙЙЙЙЙЙЙЙ \n"
+ "ЙЙЙЙЙЙЙЙЙЙЙЙЙЙЙЙЙ \n"
+ "статьи: ЦЦЦЦЦЦЦЦЦЦЦЦЦЦЦЦ\n"
+ "УУУУУУУУУУУУУУУУУ Срок: КККККККККККККККККККК\n\n"
+ "( 3 )\n"
+ "01.01.2014 - ННННННННН кем( орган): ЙЙЙЙЙЙЙЙЙЙ \n"
+ "ЙЙЙЙЙЙЙЙЙЙЙЙЙЙЙЙЙ \n"
+ "ЙЙЙЙЙЙЙЙЙЙ ЙЙЙЙЙЙЙЙЙЙЙЙЙ\n"
+ "статьи: ЦЦЦЦЦЦЦЦЦЦЦЦЦЦЦЦ\n"
+ "УУУУУУУУУУУУУУУУУ Срок: КККККККККККККККККККК\n"
+ "Комментарии : ЕЕЕЕЕЕЕЕЕЕЕЕЕЕЕЕЕЕ\n"
+ "Дополнительные отметки: ФФФФФФФФФФФФФФФФФФФФФФФ\n"
+ "ФФФФФФФФФФФФФФФ\n"
+ "ФФФФФФФФФФФФФФФФФФ Кем : ЯЯЯЯЯЯЯЯЯЯЯЯЯЯЯЯЯЯ\n"
+ "ЯЯЯЯЯЯЯЯЯЯЯЯЯЯЯЯЯЯЯЯЯЯЯЯЯЯЯЯЯЯЯЯЯЯ\n\n"
+ "( 4 )\n"
+ "08.04.2014 - ННННННННН кем( орган): ЙЙЙЙЙЙЙЙЙЙ \n"
+ "ЙЙЙЙЙЙЙЙЙЙЙЙЙЙЙЙЙ \n"
+ "ЙЙЙЙЙЙЙЙЙЙ ЙЙЙЙЙЙЙЙЙЙЙЙЙ\n"
+ "статьи: ЦЦЦЦЦЦЦЦЦЦЦЦЦЦЦЦ\n"
+ "УУУУУУУУУУУУУУУУУ Срок: КККККККККККККККККККК\n"
+ "Комментарии : ЕЕЕЕЕЕЕЕЕЕЕЕЕЕЕЕЕЕ\n"
+ "Дополнительные отметки: ФФФФФФФФФФФФФФФФФФФФФФФ\n"
+ "ФФФФФФФФФФФФФФФ\n"
+ "ФФФФФФФФФФФФФФФФФФ Кем : ЯЯЯЯЯЯЯЯЯЯЯЯЯЯЯЯЯЯ\n"
+ "ЯЯЯЯЯЯЯЯЯЯЯЯЯЯЯЯЯЯЯЯЯЯЯЯЯЯЯЯЯЯЯЯЯЯ\n"
+ "Срок: ССССССССССССССССССССССССССССССССССССС\n"
+ "СССССССССССССССССССССССССССС\n"
+ "22.12.2014 - ННННННННННННННН : НННННННННННННННН \n"
+ "НННННННННН. Убыл в: ЗЗЗЗЗЗЗЗЗЗЗЗЗЗЗЗЗЗЗЗЗЗЗЗЗЗЗЗ \n"
+ "ЗЗЗЗЗЗЗЗЗЗЗЗЗЗ\n\n"
+ "( 5 )\n"
+ "03.04.2017 - НННННННННННН кем( орган): ЙЙЙЙЙЙЙЙЙЙЙЙЙ\n"
+ "ЙЙЙЙЙЙЙЙЙЙЙЙЙЙЙЙЙЙЙЙ\n"
+ "статьи: ЦЦЦЦЦЦЦЦЦЦЦЦЦЦЦЦЦЦЦЦЦЦЦЦЦЦЦЦЦЦЦЦ\n"
+ "ууууууууууууууууууууу Срок: КККККККККККККККККККККК\n"
+ "Комментарии : ЕЕЕЕЕЕЕЕЕЕЕЕЕЕЕЕЕ\n"
+ "Дополнительные отметки: ФФФФФФФФФФФФФФФФФФФФФФФФФФФФФФФ\n"
+ "- - - -";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.DOTALL | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}