const regex = /\(\s*\d+\s\).*?(?:^$|- - - -)/gmsi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\(\\s*\\d+\\s\\).*?(?:^$|- - - -)', 'gmsi')
const str = `( 2 )
01.02.2014 - ННННННН кем( орган): ЙЙЙЙЙЙЙЙ
ЙЙЙЙЙЙЙЙЙЙЙЙЙЙЙЙЙ
статьи: ЦЦЦЦЦЦЦЦЦЦЦЦЦЦЦЦ
УУУУУУУУУУУУУУУУУ Срок: КККККККККККККККККККК
( 3 )
01.01.2014 - ННННННННН кем( орган): ЙЙЙЙЙЙЙЙЙЙ
ЙЙЙЙЙЙЙЙЙЙЙЙЙЙЙЙЙ
ЙЙЙЙЙЙЙЙЙЙ ЙЙЙЙЙЙЙЙЙЙЙЙЙ
статьи: ЦЦЦЦЦЦЦЦЦЦЦЦЦЦЦЦ
УУУУУУУУУУУУУУУУУ Срок: КККККККККККККККККККК
Комментарии : ЕЕЕЕЕЕЕЕЕЕЕЕЕЕЕЕЕЕ
Дополнительные отметки: ФФФФФФФФФФФФФФФФФФФФФФФ
ФФФФФФФФФФФФФФФ
ФФФФФФФФФФФФФФФФФФ Кем : ЯЯЯЯЯЯЯЯЯЯЯЯЯЯЯЯЯЯ
ЯЯЯЯЯЯЯЯЯЯЯЯЯЯЯЯЯЯЯЯЯЯЯЯЯЯЯЯЯЯЯЯЯЯ
( 4 )
08.04.2014 - ННННННННН кем( орган): ЙЙЙЙЙЙЙЙЙЙ
ЙЙЙЙЙЙЙЙЙЙЙЙЙЙЙЙЙ
ЙЙЙЙЙЙЙЙЙЙ ЙЙЙЙЙЙЙЙЙЙЙЙЙ
статьи: ЦЦЦЦЦЦЦЦЦЦЦЦЦЦЦЦ
УУУУУУУУУУУУУУУУУ Срок: КККККККККККККККККККК
Комментарии : ЕЕЕЕЕЕЕЕЕЕЕЕЕЕЕЕЕЕ
Дополнительные отметки: ФФФФФФФФФФФФФФФФФФФФФФФ
ФФФФФФФФФФФФФФФ
ФФФФФФФФФФФФФФФФФФ Кем : ЯЯЯЯЯЯЯЯЯЯЯЯЯЯЯЯЯЯ
ЯЯЯЯЯЯЯЯЯЯЯЯЯЯЯЯЯЯЯЯЯЯЯЯЯЯЯЯЯЯЯЯЯЯ
Срок: ССССССССССССССССССССССССССССССССССССС
СССССССССССССССССССССССССССС
22.12.2014 - ННННННННННННННН : НННННННННННННННН
НННННННННН. Убыл в: ЗЗЗЗЗЗЗЗЗЗЗЗЗЗЗЗЗЗЗЗЗЗЗЗЗЗЗЗ
ЗЗЗЗЗЗЗЗЗЗЗЗЗЗ
( 5 )
03.04.2017 - НННННННННННН кем( орган): ЙЙЙЙЙЙЙЙЙЙЙЙЙ
ЙЙЙЙЙЙЙЙЙЙЙЙЙЙЙЙЙЙЙЙ
статьи: ЦЦЦЦЦЦЦЦЦЦЦЦЦЦЦЦЦЦЦЦЦЦЦЦЦЦЦЦЦЦЦЦ
ууууууууууууууууууууу Срок: КККККККККККККККККККККК
Комментарии : ЕЕЕЕЕЕЕЕЕЕЕЕЕЕЕЕЕ
Дополнительные отметки: ФФФФФФФФФФФФФФФФФФФФФФФФФФФФФФФ
- - - -`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}