#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(\d\.){2,}"
Local $sString = "3.2.4.2. porta pellentesque " & @CRLF & _
"139. Nunc maximus maximus aliquet? " & @CRLF & _
" a) dignissim " & @CRLF & _
" b) volutpat " & @CRLF & _
" c) ullamcorper " & @CRLF & _
"" & @CRLF & _
"3.2.4.3. ligula at condimentum fringilla " & @CRLF & _
"152. Sed dapibus nulla mi, id lobortis ligula bibendum vehicula? " & @CRLF & _
" a) vestibulum " & @CRLF & _
" b) pellentesque " & @CRLF & _
" c) tempus " & @CRLF & _
" d) rutrum " & @CRLF & _
" " & @CRLF & _
"153. Lorem ipsum dolor sit amet, consectetur adipiscing elit. Sed iaculis lacus quis mi pellentesque, non auctor eros lobortis? " & @CRLF & _
" a) suscipit " & @CRLF & _
" b) vulputate " & @CRLF & _
" c) vestibulum " & @CRLF & _
" d) congue " & @CRLF & _
" " & @CRLF & _
"3.2.5. elementum quis " & @CRLF & _
" "
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")