import Foundation
let pattern = #"(\d\.){2,}"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
3.2.4.2. porta pellentesque
139. Nunc maximus maximus aliquet?
a) dignissim
b) volutpat
c) ullamcorper
3.2.4.3. ligula at condimentum fringilla
152. Sed dapibus nulla mi, id lobortis ligula bibendum vehicula?
a) vestibulum
b) pellentesque
c) tempus
d) rutrum
153. Lorem ipsum dolor sit amet, consectetur adipiscing elit. Sed iaculis lacus quis mi pellentesque, non auctor eros lobortis?
a) suscipit
b) vulputate
c) vestibulum
d) congue
3.2.5. elementum quis
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)