using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\d\.){2,}";
string input = @"3.2.4.2. porta pellentesque
139. Nunc maximus maximus aliquet?
a) dignissim
b) volutpat
c) ullamcorper
3.2.4.3. ligula at condimentum fringilla
152. Sed dapibus nulla mi, id lobortis ligula bibendum vehicula?
a) vestibulum
b) pellentesque
c) tempus
d) rutrum
153. Lorem ipsum dolor sit amet, consectetur adipiscing elit. Sed iaculis lacus quis mi pellentesque, non auctor eros lobortis?
a) suscipit
b) vulputate
c) vestibulum
d) congue
3.2.5. elementum quis
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}