import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\d\\.){2,}";
final String string = "3.2.4.2. porta pellentesque \n"
+ "139. Nunc maximus maximus aliquet? \n"
+ " a) dignissim \n"
+ " b) volutpat \n"
+ " c) ullamcorper \n\n"
+ "3.2.4.3. ligula at condimentum fringilla \n"
+ "152. Sed dapibus nulla mi, id lobortis ligula bibendum vehicula? \n"
+ " a) vestibulum \n"
+ " b) pellentesque \n"
+ " c) tempus \n"
+ " d) rutrum \n"
+ " \n"
+ "153. Lorem ipsum dolor sit amet, consectetur adipiscing elit. Sed iaculis lacus quis mi pellentesque, non auctor eros lobortis? \n"
+ " a) suscipit \n"
+ " b) vulputate \n"
+ " c) vestibulum \n"
+ " d) congue \n"
+ " \n"
+ "3.2.5. elementum quis \n"
+ " ";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}