const regex = new RegExp('(\\d\\.){2,}', 'gm')
const str = `3.2.4.2. porta pellentesque
139. Nunc maximus maximus aliquet?
a) dignissim
b) volutpat
c) ullamcorper
3.2.4.3. ligula at condimentum fringilla
152. Sed dapibus nulla mi, id lobortis ligula bibendum vehicula?
a) vestibulum
b) pellentesque
c) tempus
d) rutrum
153. Lorem ipsum dolor sit amet, consectetur adipiscing elit. Sed iaculis lacus quis mi pellentesque, non auctor eros lobortis?
a) suscipit
b) vulputate
c) vestibulum
d) congue
3.2.5. elementum quis
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}