const regex = /.+ {2,}/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('.+ {2,}', 'g')
const str = `abaxial van osovine
abbacy opatstvo
abbaino kora
abbatial opatski
abbe opat
abbé opat
abbé sveæenik`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);