#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)1013"
Local $sString = "# 配對數字(Match number)" & @CRLF & _
"" & @CRLF & _
"#下方為測試文字區塊" & @CRLF & _
"hangxiu1013@gmail.com" & @CRLF & _
"hengxiu1013@gmail.com" & @CRLF & _
"hingxiu1013@gmail.com" & @CRLF & _
"hongxiu1013@gmail.com" & @CRLF & _
"hungxiu1013@gmail.com" & @CRLF & _
"" & @CRLF & _
"#解釋:藍色部分就是透過規則 /1013/ 所配對成功的地方。" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")