const regex = /1013/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('1013', 'gm')
const str = `# 配對數字(Match number)
#下方為測試文字區塊
hangxiu1013@gmail.com
hengxiu1013@gmail.com
hingxiu1013@gmail.com
hongxiu1013@gmail.com
hungxiu1013@gmail.com
#解釋:藍色部分就是透過規則 /1013/ 所配對成功的地方。
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}