re = /1013/m
str = '# 配對數字(Match number)
#下方為測試文字區塊
hangxiu1013@gmail.com
hengxiu1013@gmail.com
hingxiu1013@gmail.com
hongxiu1013@gmail.com
hungxiu1013@gmail.com
#解釋:藍色部分就是透過規則 /1013/ 所配對成功的地方。
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end