// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)1013").unwrap();
let string = "# 配對數字(Match number)
#下方為測試文字區塊
hangxiu1013@gmail.com
hengxiu1013@gmail.com
hingxiu1013@gmail.com
hongxiu1013@gmail.com
hungxiu1013@gmail.com
#解釋:藍色部分就是透過規則 /1013/ 所配對成功的地方。
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}