using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"1013";
string input = @"# 配對數字(Match number)
#下方為測試文字區塊
hangxiu1013@gmail.com
hengxiu1013@gmail.com
hingxiu1013@gmail.com
hongxiu1013@gmail.com
hungxiu1013@gmail.com
#解釋:藍色部分就是透過規則 /1013/ 所配對成功的地方。
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}