use strict;
my $str = '# 配對數字(Match number)
#下方為測試文字區塊
hangxiu1013@gmail.com
hengxiu1013@gmail.com
hingxiu1013@gmail.com
hongxiu1013@gmail.com
hungxiu1013@gmail.com
#解釋:藍色部分就是透過規則 /1013/ 所配對成功的地方。
';
my $regex = qr/1013/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}