#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "<span\s.+?.class=\"market_listing_item_name\".*?>(.*?)</span>"
Local $sString = "<span id="result_0_name" class="market_listing_item_name" style="color: #;">Begin</span>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")