import Foundation
let pattern = #"<span\s.+?.class=\"market_listing_item_name\".*?>(.*?)</span>"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = ##"<span id="result_0_name" class="market_listing_item_name" style="color: #;">Begin</span>"##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}