$re = '~<span\s.+?.class=\"market_listing_item_name\".*?>(.*?)</span>~';
$str = '<span id="result_0_name" class="market_listing_item_name" style="color: #;">Begin</span>';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);