re = /<span\s.+?.class=\"market_listing_item_name\".*?>(.*?)<\/span>/
str = '<span id="result_0_name" class="market_listing_item_name" style="color: #;">Begin</span>'
# Print the match result
str.match(re) do |match|
puts match.to_s
end