// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"<span\s.+?.class=\"market_listing_item_name\".*?>(.*?)</span>"#).unwrap();
let string = "<span id=\"result_0_name\" class=\"market_listing_item_name\" style=\"color: #;\">Begin</span>";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}