import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<span\\s.+?.class=\\\"market_listing_item_name\\\".*?>(.*?)</span>";
final String string = "<span id=\"result_0_name\" class=\"market_listing_item_name\" style=\"color: #;\">Begin</span>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}